Delays in connectivity
Incident Report for NationBuilder
Resolved
This issue is now resolved. Response times and performance has returned to normal. If you are experiencing further issues, please reach out to help@nationbuilder.com for more assistance.
Posted Nov 17, 2017 - 16:22 PST
Monitoring
Our engineers have implemented a fix and performance is recovering more significantly. We are continuing to monitor performance very closely.
Posted Nov 17, 2017 - 11:51 PST
Update
Some customers may still be experiencing timeouts or delays despite access being restored. Our engineers are still working on a fix to mitigate slowness.
Posted Nov 17, 2017 - 11:28 PST
Update
Access to NationBuilder is being restored. Websites and control panels should be recovering regular performance.
Posted Nov 17, 2017 - 11:09 PST
Identified
Our engineers have identified the issue and are working on a fix.
Posted Nov 17, 2017 - 11:00 PST
Investigating
We are receiving reports that customers are experiencing delays in connecting to NationBuilder control panels and websites.
Posted Nov 17, 2017 - 10:59 PST