Partial outage of customer sites and control panels
Incident Report for NationBuilder
Resolved
All sites and control panels loading correctly again.
Posted Oct 07, 2016 - 06:35 PDT
Investigating
Some customers are currently experiencing issues accessing their sites and control panels.
Posted Oct 07, 2016 - 06:33 PDT