NationBuilder sites and control panels unavailable
Incident Report for NationBuilder
Resolved
This incident has been resolved.
Posted Mar 21, 2018 - 07:41 PDT
Monitoring
All sites are now accessible. We are monitoring currently.
Posted Mar 21, 2018 - 04:04 PDT
Identified
Our engineers have identified the issue and are working to resolve it currently.
Posted Mar 21, 2018 - 02:48 PDT
Investigating
Our customer sites and control panels are currently unavailable. We are investigating.
Posted Mar 21, 2018 - 02:36 PDT