Partial outage of customer sites and control panels
Incident Report for NationBuilder
Resolved
All sites and control panels should be loading as expected now. Please reach out to help@nationbuilder.com if you are still experiencing slowness or downtime.
Posted 3 months ago. May 31, 2017 - 14:15 PDT
Identified
Some customers are currently experiencing slowness or intermittent downtime while accessing their sites and control panels.
Posted 3 months ago. May 31, 2017 - 12:29 PDT