NationBuilder is temporarily unavailable
Incident Report for NationBuilder
Resolved
Access to NationBuilder should be completely restored. Please email help@nationbuilder.com if you continue to see issues.
Posted about 1 month ago. May 16, 2017 - 19:23 PDT
Monitoring
Access to NationBuilder is resolving, and we're recuperating access to websites and control panels. Please email help@nationbuilder.com if you continue to see issues.
Posted about 1 month ago. May 16, 2017 - 18:41 PDT
Identified
NationBuilder is temporarily unavailable. We are resolving the issue as we speak, and you may experience intermittent availability of the platform as this resolves.
Posted about 1 month ago. May 16, 2017 - 18:29 PDT