Performance issues with the NationBuilder Phone Support line
Incident Report for NationBuilder
Resolved
Our phone service provider has announced that their systems are operating normally. Please email help@nationbuilder.com if you are not able to reach our support team by phone during regular business hours.
Posted Oct 21, 2016 - 15:36 PDT
Monitoring
Our phone service appears to be stable, but we will continue to monitor.
Posted Oct 21, 2016 - 13:50 PDT
Identified
Our phone service provider is investigating the issue.
http://status.talkdesk.com/incidents/wkb4prx14k64
Posted Oct 21, 2016 - 09:42 PDT