Delays in 1-to-1 emails
Incident Report for NationBuilder
Resolved
Our team has mitigated the delays in 1-to-1 email delivery. Thank you for your patience and please reach out to our Support Team at help@nationbuilder.com with any questions.
Posted 3 months ago. May 11, 2017 - 17:32 PDT
Investigating
We're receiving reports that delivery of 1-to-1 emails is delayed. These emails are sent eventually, but the user interface doesn't immediately reflect delivery and the actual email is not received in the inbox until much later. We recommend that if you have clicked send on a 1-to-1 email, that you do not send it twice.
Posted 3 months ago. May 11, 2017 - 16:42 PDT