Certain tasks performing slowly
Incident Report for NationBuilder
Resolved
According to our engineers, slowness in the control panel should be mitigated. Performance should be back to normal. Please email help@nationbuilder.com if you are continuing to experience issues.
Posted 16 days ago. Nov 07, 2017 - 14:39 PST
Identified
We believe we’ve identified the issues contributing to slowness and are working towards a solution. This issue has our full attention and you may notice improvements while we work towards a solution.
Posted 17 days ago. Nov 06, 2017 - 17:49 PST
Investigating
We're receiving reports that certain customer nations have slow-performing tasks in the control panel including but not limited to imports, exports, logging contacts, filters, batch updates, and adding new blog posts.
Posted 17 days ago. Nov 06, 2017 - 16:38 PST