Issues with imports
Incident Report for NationBuilder
Resolved
We have identified the issue and resumed imports. There is no need to requeue imports that have stalled as they will just resume importing. If you should have any questions or concerns, please contact help@nationbuilder.com.
Posted 2 months ago. Mar 27, 2017 - 09:03 PDT
Investigating
We are receiving reports that some imports are stalling. We are investigating the issue and will update this status as soon as we have updates.
Posted 2 months ago. Mar 27, 2017 - 08:48 PDT