Delays in email sending and some forms processing
Incident Report for NationBuilder
Resolved
This issue should now be resolved. If you are having any issues with 1-to-1 emails or email blasts, please contact help@nationbuilder.com.
Posted 3 months ago. Sep 06, 2017 - 16:36 PDT
Monitoring
Sendgrid is seeing service return and queued emails are sending out. We will let you know when they have fully resolved the issue.
Posted 3 months ago. Sep 06, 2017 - 15:07 PDT
Identified
Our email provider is currently experiencing issues and is investigating the cause - http://status.sendgrid.com/ Some NationBuilder emails and forms are affected (for example, sending a 1x1 email from the control panel) we will update as we know more.
Posted 3 months ago. Sep 06, 2017 - 13:59 PDT