Degraded performance loading customer sites and control panels
Incident Report for NationBuilder
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 03, 2017 - 11:30 PDT
Identified
Some customers are currently experiencing slowness or intermittent downtime while accessing their sites and control panels. Our engineers are working to resolve these performance issues as soon as possible.
Posted 5 months ago. Jul 03, 2017 - 11:01 PDT