Incoming emails are not received in NationBuilder
Incident Report for NationBuilder
Resolved
Emails sent to NationBuilder-provided inboxes should be received in the control panel as expected now. Any emails sent to your NationBuilder-provided inbox during this outage should be delivered shortly. Please contact help@nationbuilder.com if you're still experiencing any issues.
Posted 4 months ago. Jun 14, 2017 - 09:51 PDT
Identified
There are reports that emails sent to NationBuilder-provided inboxes are not received in the control panel. This includes custom domain email addresses where NationBuilder is the email provider (i.e., MX records pointed at mx.emailnb.com) as well as NationBuilder email addresses like user@nationslug.emailnb.com. Our engineers have identified the problem and they are working to resolve these issues. 1:1 emails sent from the control panel, including test email blasts, should not be impacted.
Posted 4 months ago. Jun 14, 2017 - 09:19 PDT