Access issues for NationBuilder sites and control panel
Incident Report for NationBuilder
Resolved
This incident has been resolved.
Posted Nov 15, 2017 - 06:29 PST
Monitoring
We have resolved the issue and all sites should now be accessible. We are currently monitoring the situation.
Posted Nov 15, 2017 - 05:05 PST
Identified
Our engineering team are working to fix this issue now.
Posted Nov 15, 2017 - 04:58 PST
Investigating
We are aware that customers are experiencing difficulties accessing NationBuilder websites and control panel. We are investigating currently.
Posted Nov 15, 2017 - 04:07 PST