Issues with phone support system
Incident Report for NationBuilder
Resolved
Service has been restored.
Posted about 1 month ago. Aug 18, 2017 - 13:54 PDT
Update
While service is progressively coming back online, we are still working with our provider to fully restore service. We'll update again ASAP.
Posted about 1 month ago. Aug 18, 2017 - 13:42 PDT
Identified
Phone support is not available at the moment. Our phone service provider is having issues with connectivity, and we're mitigating this issue with them as we speak. Please email help@nationbuilder.com for support assistance in the interim.
Posted about 1 month ago. Aug 18, 2017 - 13:33 PDT