Phone support is down
Incident Report for NationBuilder
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 09, 2017 - 11:31 PDT
Monitoring
Our phone provider has identified the issue and deployed a fix. We are now taking phone calls, though there may be lingering issues with our vendor.
Posted 2 months ago. Oct 09, 2017 - 10:50 PDT
Investigating
The phone vendor we use for customer support is experiencing technical difficulties, so we cannot take phone calls at this time. If you need support, please email us at help@nationbuilder.com.
Posted 2 months ago. Oct 09, 2017 - 08:49 PDT