Limited Phone Support
Incident Report for NationBuilder
Resolved
This has issue has been resolved.
Posted Jun 08, 2021 - 10:21 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2021 - 09:21 PDT
Investigating
We are currently having issues with our Phone provider in effect limiting NationBuilder Phone support. Calls may seem to be drop or hang after being answered. We are investigating the issue with our Phone provider.
Posted Jun 08, 2021 - 09:12 PDT