Email blasts are not sending to recipients
Incident Report for NationBuilder
Resolved
Our engineering team has deployed a fix, and email blasts are sending normally. If you are still experiencing a problem with your email blast, please reach out to help@nationbuilder.com.
Posted 3 months ago. May 11, 2018 - 14:08 PDT
Investigating
Our engineering team has identified an issue with email blasts sent in the past 30 min (approx. 1:25pm PT). We're working to make sure that those emails are delivered and that no further email blasts are delayed.
Posted 3 months ago. May 11, 2018 - 13:56 PDT