Delays in email blasts
Incident Report for NationBuilder
Resolved
All delayed email blasts have now been sent. If you are still experiencing delays with email blasts, please email help@nationbuilder.com.
Posted May 18, 2018 - 16:35 PDT
Monitoring
Engineering has deployed a fix and delayed email blasts have resumed sending. Any blasts canceled by NationBuilder Support will not be sent.
Posted May 18, 2018 - 16:23 PDT
Update
Our engineers are still deploying the fix. We will update status as soon as emails are sending again. If you need to cancel your email, please email help@nationbuilder.com.
Posted May 18, 2018 - 16:10 PDT
Identified
Our engineers have identified delays in customer email blasts. A fix is currently being deployed. If you need to cancel your email, please email help@nationbuilder.com
Posted May 18, 2018 - 15:49 PDT