Issues with scheduled email blasts
Incident Report for NationBuilder
Resolved
Our engineers have fixed the issue. Scheduled emails should now be sent as expected. If your scheduled email did not send but needs to be sent, we recommend either rescheduling the email or sending it manually. Again, we apologize for this interruption in service.
Posted 6 months ago. Jun 27, 2018 - 19:55 PDT
Investigating
We are receiving reports that some scheduled email blasts are not being delivered. If your email blast has not been sent and is scheduled, we recommend unscheduling it at Communication > Scheduled > Cancel and sending it out manually. If the email is past the scheduled send time and needs to be sent, we recommend sending the email manually.

We apologize for this interruption in service, and our engineers are working on restoring full functionality.
Posted 6 months ago. Jun 27, 2018 - 19:34 PDT
This incident affected: Email (Email blasts).