Website access down
Incident Report for NationBuilder
Resolved
All customer sites should now be loading as normal.
Posted about 1 year ago. Mar 21, 2017 - 04:16 PDT
Investigating
Some customers in Europe are experiencing difficulties accessing their public facing sites. Our engineers are currently working to fix this issue.
Access to control panel is unaffected.
Posted about 1 year ago. Mar 21, 2017 - 03:36 PDT