Delays in email blasts
Incident Report for NationBuilder
Resolved
Performance of email blasts, geocoding, recurring imports, autodistricting, smart tags, and event expiration have stabilized. If you continue to experience delays, please email help@nationbuilder.com for more assistance.
Posted 6 months ago. Jun 05, 2018 - 13:43 PDT
Update
Our engineers continue to see performance improvements across backgrounded jobs including email blasts, geocoding, recurring imports, autodistricting, smart tags, and event expiration. Nations should expect these features to resume expected functionality.
Posted 6 months ago. Jun 05, 2018 - 13:15 PDT
Monitoring
Our engineers have implemented a fix. We are seeing email blasts resume and performance improve across the previously mentioned features.
Posted 6 months ago. Jun 05, 2018 - 13:10 PDT
Identified
Our engineers are working on reducing delays on email blasts, geocoding, recurring imports, autodistricting, smart tags, and event expiration.
Posted 6 months ago. Jun 05, 2018 - 12:59 PDT
Update
In addition to email blasts, our engineers are also noticing delays with scheduled email blasts, geocoding, recurring imports, autodistricting, smart tags, event expiration.
Posted 6 months ago. Jun 05, 2018 - 12:52 PDT
Investigating
Our engineers are investigating delays with email blasts. At the moment, some customers may experience delays in the delivery of an email blast. If you should need to cancel your email blast, please email help@nationbuilder.com and NationBuilder Support can cancel the blast for you.
Posted 6 months ago. Jun 05, 2018 - 12:41 PDT