Issues accessing NationBuilder
Incident Report for NationBuilder
Resolved
This issue has been resolved. If you continue to experience issues, please email help@nationbuilder.com.
Posted May 18, 2018 - 13:20 PDT
Monitoring
The fix has been deployed. Customer nations should be regaining accessibility shortly.
Posted May 18, 2018 - 13:14 PDT
Identified
Our engineers have identified the issue and are deploying a fix.
Posted May 18, 2018 - 13:12 PDT
Investigating
We are receiving reports that some nations are having issues accessing NationBuilder.
Posted May 18, 2018 - 13:10 PDT