Issues accessing NationBuilder
Incident Report for NationBuilder
Resolved
The issue has been resolved and all accounts should be fully accessible.
Posted Mar 18, 2020 - 12:20 PDT
Monitoring
Accounts should be available again. We are continuing to monitor.
Posted Mar 18, 2020 - 11:07 PDT
Update
We are continuing to investigate the source of the issue.
Posted Mar 18, 2020 - 10:37 PDT
Investigating
NationBuilder accounts are currently inaccessible. We are investigating.
Posted Mar 18, 2020 - 10:20 PDT
This incident affected: Control Panel (Control Panel) and Website.