Direct links to site's subpages are failing on first try

Incident Report for NationBuilder

Resolved

The issue has been resolved
Posted Mar 03, 2026 - 14:06 PST

Monitoring

We have identified and mitigated the issue. A fix has been enabled, and we are currently monitoring results
Posted Mar 03, 2026 - 14:02 PST

Investigating

We are currently investigating the issue
Posted Mar 03, 2026 - 13:41 PST
This incident affected: Website.