Send button is not available on email blasts
Incident Report for NationBuilder
Resolved
The send button should now be available for all email blasts. Please reach out to help@nationbuilder.com if you encounter any further problems sending emails.
Posted Oct 01, 2018 - 12:31 PDT
Identified
There have been several reports that the send button is missing from email blasts. Our engineers are investigating and working towards a resolution.
Posted Oct 01, 2018 - 11:58 PDT
This incident affected: Email (Email blasts).