Some tasks are performing slowly
Incident Report for NationBuilder
Resolved
Delays have been mitigated. Please reach out to help@nationbuilder.com if you are noticing any more slowness.
Posted 8 months ago. Nov 03, 2017 - 20:49 PDT
Investigating
Some customers may be experiencing delays when performing certain tasks on the control panel such as imports, exports, people updates, mailings, and filters.
Posted 8 months ago. Nov 03, 2017 - 13:02 PDT