Control Panel Donation Failure

Incident Report for NationBuilder

Resolved

This has now been resolved
Posted May 20, 2026 - 12:38 PDT

Monitoring

A fix has been deployed. We are continuing to monitor the results.
Posted May 20, 2026 - 11:40 PDT

Identified

We are continuing to work on a fix for this issue.
Posted May 20, 2026 - 11:14 PDT

Investigating

We are currently investigating the issue
Posted May 20, 2026 - 11:01 PDT
This incident affected: Donation/Payment Processing (NationBuilder Payments).