"New Email Blast Feature" Not Loading

Incident Report for NationBuilder

Resolved

The incident has been resolved.
Posted Feb 09, 2026 - 14:47 PST

Identified

We are continuing to work on a fix for this issue.
Posted Feb 09, 2026 - 14:37 PST

Investigating

We are currently investigating this issue
Posted Feb 09, 2026 - 13:48 PST
This incident affected: Email (Email blasts).