Scheduled email blasts are not sending as expected.

Incident Report for NationBuilder

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 15:29 PDT

Monitoring

We will continue to monitor for any further issues.
Posted Apr 03, 2026 - 11:30 PDT

Identified

We are continuing to work on a fix for this issue
Posted Apr 03, 2026 - 07:39 PDT

Investigating

We are currently investigating this issue
Posted Apr 03, 2026 - 07:27 PDT
This incident affected: Email (Email blasts).