Problems with Phone System
Incident Report for NationBuilder
Resolved
This incident has been resolved.
Posted Oct 18, 2016 - 12:57 PDT
Monitoring
Our phone vendor has implemented a backup mode and communications have been restored. We will continue to monitor this issue and report any additional information as it becomes available.
Posted Oct 18, 2016 - 12:15 PDT
Identified
We are experiencing problems with our phone systems and are not able to answer inbound support calls at this time. We are working with our provider to resolve the issue. If your issue is urgent, please email directly. We will post updates here every 10 minutes.
Posted Oct 18, 2016 - 12:09 PDT