Recaptcha errors blocking donations on Donation v2 pages
Incident Report for NationBuilder
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 14:17 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 13, 2025 - 13:08 PST
Investigating
We are currently investigating this issue.
Posted Jan 13, 2025 - 12:16 PST
This incident affected: Donation/Payment Processing (NationBuilder Payments).